Using ParaView

From ScorecWiki

(Difference between revisions)
Jump to: navigation, search
Revision as of 17:23, 15 August 2005
Zford (Talk | contribs)
(Serial)
← Previous diff
Revision as of 17:43, 15 August 2005
Zford (Talk | contribs)
(Calculator Filter)
Next diff →
Line 13: Line 13:
*Choose which ensa field you want to analyze by selecting it in the ''scalars'' tab. *Choose which ensa field you want to analyze by selecting it in the ''scalars'' tab.
*Click ''Accept'' *Click ''Accept''
 +====Making Vectors====
 +Make sure the scalar quantity is in front of the unit vector. If the unit vector is placed in front of the scalar quantity in the muliplication, it will cause the value to always be 1.
 +
 +Example:
 +<pre>
 +Ensa_Fields_1j*iHat + Ensa_Fields_2*jHat + Ensa_Fields_3*kHat
 +</pre>
 +
===Isosurfaces=== ===Isosurfaces===
*Apply ''Calculator'' filter. *Apply ''Calculator'' filter.

Revision as of 17:43, 15 August 2005

Contents

Before Starting

Make sure you have your ENSA Results and a copy of ParaView

Reading ENSA Results

Serial

  • Launch ParaView
  • Go to File > Open Data. Select your ENSA result.
  • Apply Filters to your result.

Parallel

Applying Filters

Calculator Filter

  • Go to Filter > Calculator
  • Choose which ensa field you want to analyze by selecting it in the scalars tab.
  • Click Accept

Making Vectors

Make sure the scalar quantity is in front of the unit vector. If the unit vector is placed in front of the scalar quantity in the muliplication, it will cause the value to always be 1.

Example:

Ensa_Fields_1j*iHat + Ensa_Fields_2*jHat + Ensa_Fields_3*kHat

Isosurfaces

  • Apply Calculator filter.
  • Go to Filter > Contour.
  • Click Accept.

Mesh Colored by Scalars

  • Apply Calculator filter.
  • Click the Display tab on the Calculator filter.
  • Change the value in the representation tab to wireframe of surface

Velocity Vectors

  • Apply Calculator filter.
  • Create velocity vector in the Calculator filter. (ex Ensa_Fields_1*iHat + Ensa_Fields_2*jHat + Ensa_Fields_3*kHat). Click Accept.
  • Go to Filter > Glyph.
  • Select your representation of the vector in the Glyph drop-down box.
  • Make sure the Orient Mode is Vector.
  • Make sure the Scale Factor is Vector Magnitude.
  • Change the Max. Number of Glyphs.
  • Click Accept.
Personal tools