Using ParaView

From ScorecWiki

(Difference between revisions)
Jump to: navigation, search
Revision as of 19:47, 15 August 2005
Zford (Talk | contribs)
(Reading ENSA Results)
← Previous diff
Revision as of 19:49, 15 August 2005
Zford (Talk | contribs)
(Creating Meta File)
Next diff →
Line 5: Line 5:
Before using ParaView to visualize your data, you must create a meta file. The meta file tells ParaView where your geometry and solution files are located as well as how many partitions of data. The meta file that you create must have an .ensa extention. Before using ParaView to visualize your data, you must create a meta file. The meta file tells ParaView where your geometry and solution files are located as well as how many partitions of data. The meta file that you create must have an .ensa extention.
-Example Meta File:+<tt>''Example Meta File:''</tt>
<pre> <pre>
GEOME:/path/to/data/geombc.dat.%d GEOME:/path/to/data/geombc.dat.%d
Line 13: Line 13:
</pre> </pre>
-The GEOME specifies where the geometriy files are located, FIELD specifies where the solution file are located, NUMPI specifies how many pieces the data was partitioned into, and TIMED specifies if there is time step support or not.+GEOME specifies where the geometriy files are located, FIELD specifies where the solution file are located, NUMPI specifies how many pieces the data was partitioned into, and TIMED specifies if there is time step support or not.
 + 
===Serial=== ===Serial===
*Launch ParaView *Launch ParaView

Revision as of 19:49, 15 August 2005

Contents

Before Starting

Make sure you have your ENSA Results and a copy of ParaView

Reading ENSA Results

Creating Meta File

Before using ParaView to visualize your data, you must create a meta file. The meta file tells ParaView where your geometry and solution files are located as well as how many partitions of data. The meta file that you create must have an .ensa extention.

Example Meta File:

GEOME:/path/to/data/geombc.dat.%d
FIELD:/path/to/data/restart.0.%d
NUMPI:2
TIMED:0

GEOME specifies where the geometriy files are located, FIELD specifies where the solution file are located, NUMPI specifies how many pieces the data was partitioned into, and TIMED specifies if there is time step support or not.

Serial

  • Launch ParaView
  • Go to File > Open Data. Select your ENSA result.
  • Apply Filters to your result.

Parallel

Applying Filters

Calculator Filter

  • Go to Filter > Calculator
  • Choose which ensa field you want to analyze by selecting it in the scalars tab.
  • Click Accept

Making Vectors

Make sure the scalar quantity is in front of the unit vector. If the unit vector is placed in front of the scalar quantity in the muliplication, it will cause the value to always be 1.

Example:

Ensa_Fields_1j*iHat + Ensa_Fields_2*jHat + Ensa_Fields_3*kHat

Isosurfaces

  • Apply Calculator filter.
  • Go to Filter > Contour.
  • Click Accept.

Mesh Colored by Scalars

  • Apply Calculator filter.
  • Click the Display tab on the Calculator filter.
  • Change the value in the representation tab to wireframe of surface

Velocity Vectors

  • Apply Calculator filter.
  • Create velocity vector in the Calculator filter. (ex Ensa_Fields_1*iHat + Ensa_Fields_2*jHat + Ensa_Fields_3*kHat). Click Accept.
  • Go to Filter > Glyph.
  • Select your representation of the vector in the Glyph drop-down box.
  • Make sure the Orient Mode is Vector.
  • Make sure the Scale Factor is Vector Magnitude.
  • Change the Max. Number of Glyphs.
  • Click Accept.
Personal tools