Using ParaView

From ScorecWiki

(Difference between revisions)
Jump to: navigation, search
Revision as of 17:20, 16 August 2005
Zford (Talk | contribs)
(Applying Filters)
← Previous diff
Revision as of 17:29, 16 August 2005
Zford (Talk | contribs)
(Creating Isosurfaces)
Next diff →
Line 40: Line 40:
*Go to the Parameters tab and add values that you would like to generate an isosurface for. You may also generate a range of values here, or delete values you do not wish to use. *Go to the Parameters tab and add values that you would like to generate an isosurface for. You may also generate a range of values here, or delete values you do not wish to use.
*Click ''Accept'' when you are done. This should generate your isosurface. *Click ''Accept'' when you are done. This should generate your isosurface.
 +[[Media:Create-isosurface.mp4|Video: Creating an Isosurface]]
[[Image:Isosurface.png|thumb|600px|none|Isosurface in ParaView]] [[Image:Isosurface.png|thumb|600px|none|Isosurface in ParaView]]

Revision as of 17:29, 16 August 2005

Contents

Before Starting

Make sure you have your ENSA Results and a copy of ParaView

Reading ENSA Results

Creating Meta File

Before using ParaView to visualize your data, you must create a meta file. The meta file tells ParaView where your geometry and solution files are located as well as how many partitions of data. The meta file that you create must have an .ensa extention.

Example Meta File:

GEOME:/path/to/data/geombc.dat.%d
FIELD:/path/to/data/restart.0.%d
NUMPI:2
TIMED:0

GEOME specifies where the geometriy files are located, FIELD specifies where the solution file are located, NUMPI specifies how many pieces the data was partitioned into, and TIMED specifies if there is time step support or not.

Serial

  • Launch ParaView
  • Go to File > Open Data. Select your ENSA result.
  • Apply Filters to your result.

Parallel

Applying Filters

Making Vectors

Make sure the scalar quantity is in front of the unit vector. If the unit vector is placed in front of the scalar quantity in the muliplication, it will cause the value to always be 1.

Example:

Ensa_Fields_1j*iHat + Ensa_Fields_2*jHat + Ensa_Fields_3*kHat

Creating Isosurfaces

  • Apply Calculator filter by going to Filter > Calculator.
  • Enter equation that you wish to solve for into the calculator and click Accept.
  • Go to Filter > Contour.
  • Go to the Display tab and make sure the Color by: is set to Point Result
  • Click Edit Color Map...'.
  • Change the Resolution. This sets the number of different colors in the color map.
  • Click Reset Range and then click Back.
  • Go to the Parameters tab and add values that you would like to generate an isosurface for. You may also generate a range of values here, or delete values you do not wish to use.
  • Click Accept when you are done. This should generate your isosurface.

Video: Creating an Isosurface

Isosurface in ParaView
Enlarge
Isosurface in ParaView

Creating a Mesh Colored by Scalars

  • Go to the Display tab.
  • Change Representation to Wireframe of Surface
Isosurface Mesh in ParaView
Enlarge
Isosurface Mesh in ParaView

Displaying Velocity Vectors

  • Apply Calculator filter by going to Filter > Calculator.
  • Enter equation that you wish to solve for into the calculator and click Accept.
  • Go to Filter > Glyph.
  • Select your representation of the vector in the Glyph drop-down box.
  • Change the Max. Number of Glyphs' to the max number of glyphs you would like to display.
  • Click Accept.

Creating Streamlines

  • Apply Calculator filter by going to Filter > Calculator.
  • Create a velocity vector.
  • Click Accept.
  • Go to Filter > Streamtracer.
  • Change the Seed to either Point Cloud or Line.
  • Click Accept.
  • Highlight the stream in the selection window.
  • Go to Filter > Tubes or Filter > Ribbons.
  • Adjust parameters and click Accept.
Personal tools